The data is saved and loaded , but is not applied in the scene.

Discussion and help for Easy Save 3
Post Reply
rauletdev
Posts: 1
Joined: Mon Aug 08, 2022 2:13 am

The data is saved and loaded , but is not applied in the scene.

Post by rauletdev »

Hello goo morning,

I'm trying basic use of Easy Save with multiple SaveGame files, but for some reason is not applying the loaded data to the object in the scene.
when I get the logs of the transform, the data was applied to it, but even that, the editor show me the object with his default values.

I'm applying the data with similar script model as your examples.
I don't know if I'm missing something.
Here is a video that show my code and the situation.
https://1drv.ms/v/s!As-1FuvmVn5un7lotFz ... g?e=vnHTE9

As well I notice, that when I tried with a single save, It was working.
Also once in a while it work, idk why, but 1 load of every 20 or 30 it get the data applied.

Thank you,
Raul.

User avatar
Joel
Moodkie Staff
Posts: 4198
Joined: Wed Nov 07, 2012 10:32 pm

Re: The data is saved and loaded , but is not applied in the scene.

Post by Joel »

Hi Raul,

I can see an error in your code. Your ES3.KeyExists call is looking in the default file (because you've not specified a filename), but when loading (and presumably saving), you've specified a filename. You should specify the same filename for all of your Easy Save calls.

If this isn't the error, please could you create a new project with a basic scene which replicates your issue and private message it to me with instructions so I can see exactly what is happening.

All the best,
Joel
Joel @ Moodkie Interactive
Purchase Easy Save | Contact | Guides | Docs | Getting started

Post Reply